2012年4月10日 星期二

XOOPS好用模組:Tinyd

XOOPS好用模組
XOOPS好用模組介紹
模組名稱:tinyd
模組版本:2.3
模組語系:tchinese_utf8
更新日期:2013/05/19
下載網址:https://www.box.com/s/58t0zxyze9zqzo7ujngh

tinyD則是TinyContent的改良版,是XOOPS很好用的內容管理模組,內建所見即所得的編輯介面,並可以安裝多個模組,目前可安裝tinyd0~tinyd9個模組。

而這個版本,我做了一些小調整,將原本SPAW編輯介面拿掉,改成Tad老師的fckediter,也保留Xoops2.5版內建的tinyMCE可供選擇,不過要使用Tad老師的fckediter,需要額外安裝Tadtool模組。

Tadtool版本建用最新版,目前測過1.8版沒問題。


14 則留言:

  1. 您好,安裝tinyd後要安裝第2個,改tinyd檔名後,在模組安裝中,第2個tinyd模組沒有圖示,無法編輯,請問是什麼問題?

    回覆刪除
    回覆
    1. 請問你的tinyd的目錄如何命名?
      正確命名方式:tinyd
      tinyd0~9

      刪除
  2. 第一個為tinyd,安裝完後,複製一個命名為tinyd0,在回到模組要安裝時,就沒有圖示,安裝完後只顯示tinyd0沒有圖示,所以無法編輯

    回覆刪除
  3. 請問這個下載網址好像不能下載了

    回覆刪除
    回覆
    1. 我剛才測試可以正常下載,或許空間有流量限制

      刪除
  4. 您好,請問一下可否重新分享檔案?Thx~~~

    回覆刪除
    回覆
    1. 不小心把box整個砍掉了,我又重新上傳了。

      刪除
  5. 請問我安裝時出現以下訊息
    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '(14), created datetime NOT NULL default '2001-1-1 00:00:00', html_header tex' at line 15
    這該怎麼處理呢?謝謝

    回覆刪除
  6. 更正我照蓮姐方式修改19行及最下方,已經可安裝了,但無法進入編輯....

    回覆刪除
    回覆
    1. 是否能提供一下您的環境?
      XOOPS版本
      Apach
      Mysql
      PHP
      這些資訊,讓我了解一下,謝謝

      刪除
    2. 剛才發現tinyd模組,有些寫法比較舊,
      比較會出現錯誤,大多都是安裝時,資料表建立方方,寫法是舊有mysql的用法,新的mysql伺服器未畢支援。

      建議你先將模組移除,然後到sql/目錄下,將每個.sql檔中的
      「TYPE=MyISAM」改成「ENGINE=MyISAM」

      另外就是將「last_modified timestamp(14),」改成「 last_modified datetime NULL,」

      應該可以解決您的問題!!

      刪除
  7. 大大~還是不行^^麻煩你幫我測試看看~謝謝

    xoops版本2.5.6
    Apach2.2.3
    Mysql5.5.28
    PHP5.3.14

    回覆刪除
  8. 大大不好意思,好像可以了,我照你上面的方法,再加入http://xoops.tn.edu.tw/modules/xforum/viewtopic.php?topic_id=12560&forum=1&post_id=48877#threadtop
    看起來好像解決了,還沒測試QQ

    回覆刪除
  9. 不要再用上述的版本
    新的版本如下:
    可以去下載,非常好用
    http://blog.allenplay.net/

    wu Allenplay 真偉大!!

    回覆刪除

不管走過路過,記得都要留言